Airsoft Canada
007 Licence to Shoot

Go Back   Airsoft Canada > Discussion > Doctor's Corner
Home Forums Register Gallery FAQ Calendar
Retailers Community News/Info International Retailers IRC Today's Posts

problem with shooting semi

:

Doctor's Corner

Reply
 
Thread Tools
Old July 18th, 2007, 18:57   #1
Mighty Mouse
 
Mighty Mouse's Avatar
 
Join Date: May 2003
Location: Burlington, Ontario
Send a message via MSN to Mighty Mouse
problem with shooting semi

This isn't trigger seizure or its a little different anyway.
I have an MC51 thats about 4 years old, lightly used, and when the trigger is pulled in semi it is as if the battery isnt even connected. In auto it shoots fine. I figured it was due to grease on the electrical contacts in the gearbox so I went in and wiped everything down good and clean. The problem persists though and I don't know what it could be.
Mighty Mouse is offline   Reply With Quote
Old July 18th, 2007, 19:42   #2
CDN_Stalker
Official ASC Bladesmith
 
CDN_Stalker's Avatar
 
Join Date: Jul 2003
Location: Ottawa, Ont.
Send a message via MSN to CDN_Stalker
When you install the lower receiver/grip, do you make sure the selector lever in semi position when you push it up the rest of the way?
CDN_Stalker is offline   Reply With Quote
Old July 18th, 2007, 20:10   #3
Mighty Mouse
 
Mighty Mouse's Avatar
 
Join Date: May 2003
Location: Burlington, Ontario
Send a message via MSN to Mighty Mouse
the selector lever has to go on after the lower receiver is put in place on G3 series guns so you cant select semi when sliding it on.
I guess I'll keep tinkering with it and see if I can fix it. I've never encountered anything like this before.
Mighty Mouse is offline   Reply With Quote
Old July 19th, 2007, 12:33   #4
wKnight
 
wKnight's Avatar
 
Join Date: Apr 2005
Location: Moncton, NB
There’s really only one way the selector switch can interface with selector plate so it either goes together or it doesn’t. selector position is irrelevant because the parts will move to interface properly and come together. if they dont move it wont go together.

in any case it certainly wouldn’t cause an issue like this unless one or the other was deformed... or forced together.

check your selector plate and see if the copper plate on it is bent or deformed in some way. if the selector plate looks fine then its probably an issue with the switch assembly prongs. this is a common thing on old guns as these parts just ware out.

Last edited by wKnight; July 19th, 2007 at 12:38..
wKnight is offline   Reply With Quote
Old July 19th, 2007, 12:55   #5
LyquidFyre
 
LyquidFyre's Avatar
 
Join Date: Nov 2005
Location: Southern Ontario/GTA
Strange....I have an MC51 as well and I once had a problem with the trigger sticking back when shooting in semi but that was due to the return spring not sitting properly on the trigger.

The selector switch/bushing/washer on the body of the MC51 did cause a slight bulge out once when i was re-assembling which had the plate and switch misaligned.
LyquidFyre is offline   Reply With Quote
Old July 19th, 2007, 13:25   #6
CDN_Stalker
Official ASC Bladesmith
 
CDN_Stalker's Avatar
 
Join Date: Jul 2003
Location: Ottawa, Ont.
Send a message via MSN to CDN_Stalker
Quote:
Originally Posted by Mighty Mouse View Post
the selector lever has to go on after the lower receiver is put in place on G3 series guns so you cant select semi when sliding it on.
I guess I'll keep tinkering with it and see if I can fix it. I've never encountered anything like this before.
Sorry, I meant the plastic plate inside needs to be set to semi position, you have to use the lever to postion it then remove to install the lower. I've had problems with my two MP5s by not setting it to the semi position when reinstalling the lower receiver.
CDN_Stalker is offline   Reply With Quote
Old July 21st, 2007, 02:50   #7
Mighty Mouse
 
Mighty Mouse's Avatar
 
Join Date: May 2003
Location: Burlington, Ontario
Send a message via MSN to Mighty Mouse
the problem seems fixed now. I lightly sandpapered the copper bit behind the selector plate and the two prongs from the gearbox and it seems to be shooting in semi without fail. I will see how long it lasts.
Mighty Mouse is offline   Reply With Quote
ReplyTop


Go Back   Airsoft Canada > Discussion > Doctor's Corner

Bookmarks

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Airsoft Canada
007 Licence to Shoot

All times are GMT -4. The time now is 02:31.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.